Home / Articles / Notebooks / Acer Aspire 5740G: how to flash KBC BIOS (reasons - no power, doesn't charge, no LED)

Acer Aspire 5740G: how to flash KBC BIOS (reasons - no power, doesn't charge, no LED)

Acer Aspire 5740G: how to flash KBC BIOS (reasons - no power, doesn't charge, no LED)
Acer Aspire 5740G: how to flash KBC BIOS (reasons - no power, doesn't charge, no LED)
Authors: Anton Muchychka
  • Currently 0 out of 5 Stars.
  • 1
  • 2
  • 3
  • 4
  • 5
Rating: 0/5 (0 votes cast)

Thank you for rating!

You have already rated this page, you can only rate it once!

Your rating has been changed, thanks for rating!

Log in or create a user account to rate this page.

Laptop recovery by flashing KBC BIOS (MX25L1005) using a programmer.

I have already described the process of flashing BIOS in the article Lenovo IdeaPad B560 with similar symptoms so I'll skip this part of the explanation. The chip itself MX5L1005 (the one you need flash) is located right next to the super I/O Nuvoton WPC876xL or WPCE77nx or NPCE78mx.

Acer Aspire 5740G motherboard MBPM601002 48.4GD01.01M 09285-1M

Acer Aspire 5740G motherboard MBPM601002 48.4GD01.01M 09285-1M

Before you rush into soldering the chip out and flashing it with the programmer you have to make sure that the problem is in the BIOS. To do this we need a digital oscilloscope (I use Rigol DS1052E 50MHz). In order to check the BIOS you have to connect one end of the oscilloscope to the first leg of the BIOS chip.

First leg of BIOS chip

Now watch the oscilloscope.

No data exchange

No data exchange. Most likely the firmware is crashed. So we flash the firmware using the programmer - W04AC322.bin W04AC322.bin 128.00 kB.

Now we solder the chip back, connect power supply and try looking for data exchange again.

Data exchange detected

Data exchange detected! Now reassemble… reconnect… and done - notebook restored.

Important notice: do not repair or modify this device if it's still under warranty.

Read also

Discussion (total 12 comments)

October 24, 2013 at 08:03 am
thank you sir
for shearing this
Otakar Dvorak
January 08, 2014 at 11:08 am
afshin oliayee
February 08, 2014 at 01:40 am
Thank you a lot.
J Silva
April 05, 2014 at 06:11 am
You sir, are awesome! Thank you!
September 04, 2014 at 01:20 pm
I got similar problem with acer 5750zg , my question is may I use this same firmware from 5740g ?
Anton Muchychka
Anton Muchychka
September 17, 2014 at 08:03 am
Hello Mihailo from laptop servis Beograd!
Use this one: http://hardware-today.com/tips/notebooks/download_working_bios_dump_image_for_acer_aspire_5750zg
June 07, 2015 at 02:46 am
I have a similar problem with my Acer Aspire Timeline X 3820TG. Where can I get the KBC Bios Image? Thanks a lot.
August 04, 2015 at 06:43 am
Thank you for this great guide, Managed to fix one with the same problem.
May 05, 2016 at 07:55 pm

I recovered bios of my friend's Aspire 5740g using CH341A Programmer!
Thank you very much for your clear instructon and dump file!
I have a question: Now, after recovering with procedure above, do we need load bios using Crisis Disk or recovery is enough and new bios loaded? I mean, after reassemble, will laptop launch?
(Before, laptop worked. I tried to update bios and it turned off on half way, then it became a brick. Just before writing this, I recovered bios using programmer, and now I think: reassemble it or not?)
Looking forward to your reply!
Thanks in advance!

May 06, 2016 at 07:59 am
Now I reassembled it, connected to a power but no reaction!
What I need to do next?
May 06, 2016 at 08:16 am
No reaction, I mean, even power led doesn't work when I connect to a power cable.
August 03, 2020 at 12:39 pm
Thanks, I followed your steps and it woked great on this old laptop!
It suddenly stopped working without any led light when plugged. After checking DC jack etc, checked EC BIOS and S5_ENABLE had 0 volts. After flashing it, resolder, plugged the board and the leds were back on :)

When reassembling, make sure all connections are alright, otherwise you might have a dead black screen and the laptop self booting... Remove hdd, ram, check all plugs and pins for shorts, dust etc. In my case the ram was not properly inserted.

Log in or create a user account to post a comment.


Quick navigation